Oracle clone failing with INS-40426

Recently I’ve seen this error in one of the clone operations.

— Copied the binary tar and executed

export ORACLE_HOME=/u01/app/oracle/product/12.1.0/grid; export PATH=$ORACLE_HOME/bin:$PATH; export LD_LIBRARY_PATH=$ORACLE_HOME/lib:$ORACLE_HOME/lib32:$LD_LIBRARY_PATH; export LIBPATH=$ORACLE_HOME/lib:$ORACLE_HOME/lib32:$LIBPATH; export TNS_ADMIN=$ORACLE_HOME/network/admin;

runInstaller -silent -clone ORACLE_HOME=/u01/app/oracle/product/12.1.0/grid ORACLE_BASE=/u01/app/oracle ORACLE_HOME_NAME=Ora12102_Grid

This invoked runInstaller from  /u01/app/oracle/product/12.1.0/grid.

Oracle documentation was not really helpful. Metalink did not had any references to this.

INS-40426: Grid installation option has not been specified.

Cause: n/a
Action: n/a

But when executed from /u01/app/oracle/product/12.1.0/grid/oui/bin, it worked.

This error is caused due to “-formCluster” parameters which is passed in $ORACLE_HOME/runInstaller

This script defaults BUNDLE to value “crs”, which executes a CLI with a parameter -formCluster

BUNDLE=crs
….
….
….
case “$BUNDLE” in

crs)
$CMDDIR/install/.oui $* -formCluster -J-Doracle.install.setup.workDir=$CWDDIR -J-D${CVU_OS_SETTINGS}

Advertisements
This entry was posted in 12c Upgrade issues, Oracle Database Cloning, Oracle Software Install / Deinstall and tagged , , , , , , , , . Bookmark the permalink.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s